Issue:- The Issue was first recognised after we expose a service using the Nodeport and tried to access over the localhost on other node followed by Nodeport number. But the curl request failed with timeout On Inspecting the containers of the master node one of the containers of the calico node was not ready. When I used the describe container for that service it gave the error mentioned below. Error:- Normal Created 14m kubelet Created container calico-node Normal Started 14m kubelet Started container calico-node Warning Unhealthy 14m (x3 over 14m) kubelet Readiness probe failed: calico/node is not ready: BIRD is not ready: Error querying BIRD: unable...
Error:- We have been using Gitlab and recently I got the following error while pushing my change to the Gitlab Repository remote: remote: ======================================================================== remote: remote: ERROR: Your SSH key has expired. remote: remote: ======================================================================== remote: fatal: Could not read from remote repository. Cause:- The reason for this failure was that i created a ssh key about a year ago and gitlab by default puts a security policy that your ssh key will get expire after 1 year. This is something built in to improve security in Gitlab now because that timeperiod has elapsed of 1 year thats why it gives that error of ssh key has expired.
Issue:- The issue occurs when trying to install the jenkins on the Centos7 EC2 Instance in the AWS. # yum install jenkins -y Error:- --> Finished Dependency Resolution Error: Package: jenkins-2.303.1-1.1.noarch (jenkins) Requires: daemonize You could try using --skip-broken to work around the problem You could try running: rpm -Va --nofiles --nodigest Cause:- Basically daemonize runs a command as a Daemon in the Centos. Since the package is missing in the version of the Centos you running thats why this error is coming. Think of it like a dependency which is required by the Jenkins to run but since you missing on the Daemonize thats why its giving the error. Resolution:- Daemonize doesn't ship in the default repository thats why yum is not able to resolve it. You will need to install the Daemonize from the Epel repository which is the extra package for enterprise linux as # yum install epel-release -y # yum install daemonize -y Than you can...
Comments
Post a Comment